Resetting a Project's Display Settings

If you experience any problems with elements of Scrivener’s user interface behaving oddly or appearing strange, that you can’t fix by changing settings or preferences and that only occurs with a single project, then a good first troubleshooting step will be to reset your project's user interface settings.

Every project has a file that determines the size of the window, how the Binder, Editor and Inspector display, settings such as colours, and that stores options set in the View menu. Everything that determines how a project is seen and used is considered part of its display, or interface settings.

Saving your Settings

If you don’t want to lose settings that you have changed from the defaults then you can save your preferences before resetting the user interface, and then restore them later. This step is optional.

  1. With the project open, go to Window ▸ Layouts ▸ Manage Layouts...
  2. Click the + button to create a new layout, and check the two optional boxes in the right pane, below the screenshot thumbnail.
  3. You may now proceed with resetting your interface settings by following the instructions below. Once you've done that, you can use the Window ▸ Layouts sub-menu to select the layout that you created.

Clearing the Project Interface Settings

  1. With the project open, simply click on the File menu, hold down the (Alt) key, and then select the Close Project and Clear Interface Settings menu command which appears.

    That's it, you're done! Your project will be closed and you can skip to the Reloading the Project section.

Manually Resetting the Interface if a Project will not Open

If a project will not open and causes Scrivener to crash then you'll need to reset the user interface file manually. This isn't hard to do, but you might want to create a backup first, since you'll have to edit the project's internal files by hand:

  1. First locate the project in Finder and right-click on it, selecting Compress 'project name'.

    This zip file will contain every aspect of your project. If the following steps make things worse, simply delete the edited copy of your project and double-click this .zip file to extract a new fresh copy.

  2. Right-click on the project again and select Show Package Contents.

  3. Open the Settings folder.

  4. Drag the ui.plist and ui-common.xml files to the Trash in your Dock. Scrivener 2 projects will only contain the ui.plist file.

  5. At the top-left of the Finder window use the < button until you see the project displayed, as it normally is, as a single file with the Scrivener icon.

Reloading the Project

When the project is reloaded for the first time, it will be in a default state. All items in the binder will be collapsed, and nothing will be selected in the main editor. This is the safest state in which a project can be opened, from there everything you do to change the window, expanding folders and selecting items, will be done afresh.

If you find the problem returns with a saved layout, then go back to Window ▸ Layouts ▸ Manage Layouts... and select the layout in the list and then click the gear icon and choose Export Selected Layout to export the layout to a file, and then send it to mac.support@literatureandlatte.com as an attachment. Please include a detailed description of the problem, and the steps we will need to take to reproduce it.

If you didn't use a layout, but the problem returns once you start changing your settings back to how they were, then use the prior instructions for manually resetting the interface, but this time instead of moving the files to the Trash, move it to your desktop and attach it to an email, letting us know which settings you changed most recently.