“Project not in a recommended save location” error

If, when you open a project, you see a Project not in a recommended save location warning (like the one below), this means that you are trying to open the project from Scrivener's automatic backups directory.

Screenshot: Backup location warning

The automatic backup directory is the location specified under Scrivener > Preferences > Backup as your "Backup location" (by default, this will be under ~/Library/Application Support/Scrivener/Backups, though you may have changed this).

You should never open a project directly from the automatic backups directory, because it is possible that another automatic backup could overwrite the project while you are working on it. To elaborate:

  1. When you create a Scrivener project, you are asked where to save it. You then choose a location on disk where that project's file (with the extension ".scriv") should be stored. For instance, you might choose to store it in your "Documents" directory, or somewhere on Dropbox. This is exactly the same as when you create and save a Word document, say.

  2. Scrivener has an "Automatic Backups" feature that is turned on by default. This can be controlled from the "Backups" section of Scrivener's Preferences. (You can also override backup options for a particular project via Project > Project Settings if you want different backup settings for only one project.)

  3. The first time you launch Scrivener, you are asked to choose its automatic backups location - the folder in which automatic backups will be stored. You can check or change this location at any time via Scrivener's Preferences.

  4. By default, every time Scrivener closes, it will make a backup of the project - that is, a copy, usually in ZIP file format - into the automatic backups folder.

  5. Also by default, Scrivener only keeps around the latest five copies of any given project, and deletes older ones.

So, with automatic backups turned on, you have the "live" version of the project that is located wherever you chose to save it when you first created it, and you also have backup copies of the project in the automatic backups directory. This way, if anything ever happens to your project, you can retrieve a backup from the backups directory. (It's a good idea, therefore, to have the backups folder somewhere that is safe, such as on an external hard drive or on Dropbox.)

You can probably see the problem with trying to work on a project that is stored inside the automatic backups folder: it can end up getting deleted or overwritten by another backup, because of (4) and (5) above.

Restoring Backups

If you ever need to restore your project from a backup copy, here's what to do:

  1. Navigate to your automatic backups folder. (If you can't remember where it is, go to Scrivener > Preferences > Backup and click the Open backup folder... button.)

  2. Find the latest backup of your project.

  3. Copy or move it to another directory (e.g. your ~/Documents directory or wherever you store your writing).

  4. If necessary, unzip it.

  5. Open the project in Scrivener.

Refer to §5.2.3 Restoring from Backups in the Scrivener Manual (available under the Help menu) for further and more detailed advice.

What Not to Do

  • Do not choose as your automatic backups folder the same directory into which you store and work on live projects.

  • When you restore a project from the backups folder, do not open it while it is still in the backups folder.

If you do the latter, that's when you will see the Project not in a recommended save location error.

What to Remember

The most important things to bear in mind are these:

  1. Always know where your projects are located on disk. You choose this location when you create a project, and you can check it at any time for a given project by going to File > Show Project in Finder.

  2. Be aware of where your automatic backups are located. You can check or change this at any time via Scrivener > Preferences > Backup.

  3. Keep (1) and (2) separate: don't work on projects while they are stored in the backups folder.

Follow these simple rules and you will not run into any issues or see the "Project not in a recommended location" message.