Assigning or Changing Keyboard Shortcuts in Scrivener for Mac

There may be certain menu items that you find yourself using a lot for which there is no keyboard shortcut, or for which you find the keyboard shortcut overly convoluted. Fortunately, the ability to change or assign keyboard shortcuts to menu items is built right into OS X itself, although it’s easy to miss. So, if you would like to change the key combinations assigned to commands in the Scrivener menus, or if you want to add a keyboard shortcut to a command that doesn’t have one, here's how:

  1. Go to your System Preferences (available from the Apple menu from any application).
  2. Click on "Show All" at the top if necessary.
  3. Under the “Hardware” section, click on “Keyboard” (or “Keyboard & Mouse” in Leopard and below).
  4. In the Keyboard (& Mouse) pane, select the “Keyboard Shortcuts” tab.
  5. Select “Application Shortcuts” in the list on the left (note that this step is not required on Leopard and below).
  6. Click on the ”+” button. A sheet will appear.
  7. From the “Application” pop-up button, choose Scrivener.
  8. In the “Menu Title” text field, enter the exact name of the command you want to add. This should exactly match the name of the menu item in Scrivener (capitalisation matters). For instance, if you wanted to add a keyboard shortcut to the Edit > Insert > Image From File… menu item, you would type “Image From File…” in this text field (including the ellipses). If you wanted to change the keyboard shortcut for the Edit > Paste and Match Style menu item, you would type “Paste and Match Style”.
  9. Click in the “Keyboard Shortcut” text field and then hold down the combination of keys that you want for the new shortcut.
  10. Click on “Add”.
  11. Close the System Preferences.

That’s it! When you return to Scrivener, the new keyboard shortcut should be up and running.

Fixing Conflicts

Note that keyboard shortcuts on OS X work by scanning the menus from left-to-right looking for a menu item matching the shortcut pressed. If you find that the shortcut you assigned doesn't work, or does something unexpected, it may be that the keyboard shortcut you chose is already assigned to a different menu item. In that case, you can either pick a different shortcut, or you can locate the menu item with which it clashes and go through the above process again to assign a different shortcut to the clashing menu item. (If the shortcut still doesn't work, you should ensure that the shortcut you assigned isn’t one reserved by the system.)

Tips

Some menu items change name depending on the context; for such items, you may need to assign the same keyboard shortcut for each of their possible names. For instance, the Edit > Add Link... menu item can sometimes change its title to become Edit > Edit Link... Therefore, to add a keyboard shortcut to that item that would work consistently, you would need to add the same shortcut twice, once for "Add Link..." and again for "Edit Link...".

Sometimes a menu title will be used more than once. This most often happens with titles that are created dynamically from your project information. A good example of this is View > Collections > Name Of Your Collection and Documents > Add to Collection > Name Of Your Collection. You could create a shortcut called "Name Of Your Collection", but this would get bound to the initial shortcut, which shows the tab in your Binder, not the command that files the current document into that collection. To specifically target a certain menu, you also need to type in its menu hierarchy. This is done in one of two ways, depending on your OS version.

  • Mac OS X 10.8 (Mountain Lion): Insert a > character between each menu level: Documents>Add to Collection>Collection Name.
  • Mac OS X 10.9 (Mavericks): Insert -> between each menu level: Documents->Add to Collection->Collection Name.