Project and Document Templates

Built-In Templates

When you first open Scrivener, or when you use the "New Project..." command from the File menu, you will be met with the following Project Templates window:

Screenshot of the project templates window

This window includes all of our starter templates, such as Novel, Documentary Script, Poem, or even Recipe Collection. These templates are fully customizable, and are not designed to constrict you in any way, but rather to give you a starting point. The template will gently guide you through the process of organizing and writing for a particular form or medium in Scrivener.

Templates are especially helpful for new Scrivener users who aren't sure how they might use the Binder to organize their work, or who would prefer to have some simple document templates available to them upon getting started. For example, the "Novel (Parts)" template comes with a pre-structured Binder that includes Part and Chapter folders, as well as Scene documents within them. It also includes Character and Setting sheets in the Templates folder, which you can use to begin jotting down ideas about the people and the world you're creating.

If there is anything included in the template that you don't particularly need or that doesn't fit with your workflow, you can go ahead and move it to the Trash, or make the necessary changes to that item so that it suits you better.

Project Templates vs Document Templates

There are two types of templates that you may want to play around with in Scrivener. Project templates, as discussed above, are pre-populated Scrivener projects that contain items which may be useful for beginning a manuscript of a certain medium. Document templates, on the other hand, are documents you can create within a project to which you can assign template status.

In most of the built-in project templates, you'll find a "Templates" folder* in the Binder containing documents that have a small "T" icon affixed to them. Any document you place in this folder will be assigned template status, so when you create a new document via Add > New From Template..., you will be able to select that document from the list.

Binder screenshot of the small blue template icon

Screenshot illustrating the "New from Template" command

Document templates are helpful if, say, you're writing a series with many characters, and you want to make sure each character is fleshed out in the same way. To do this, you may create a document containing a hundred character interview questions and call it "Character Interview", then add it to your Templates folder. Next time you want to create a character, you can begin by adding a new Character Interview document to your Binder. This process is far easier than copying and pasting these interview questions into a new document every time!

*If you're not using a project template that already includes a "Templates" folder, you can assign your own by creating the folder in your Binder, then navigating to Project > Project Settings > Special Folders and selecting that folder from the "Templates Folder" dropdown menu. Now every document you add to that folder will be assigned template status, as indicated by the "T" affixed to the document icon.

Screenshot of the Special Folders section of the Project Settings window

Creating Your Own Templates

If you find that you often use the same structure or reference documents when starting a project, or if you like to have the same document templates on hand whenever you create a new project, you may benefit from creating your own project template.

  1. Create a new project that includes all of the elements you would like at the starting point of a project (i.e., you'll want to populate the project with any general folders, files, document templates, references, external bookmarks, etc. that you want available when you first create the project).
  2. When the project is ready, go to File > Save As Template.... You will be prompted to create a name for the template and assign it a category and icon. Click OK when you're done.
  3. The template will now be available in the Project Templates window under whatever category you chose in Step 2.

If you would like to change the name, icon, or category of the template after it is created, you can do so at any time by right-clicking on the template in the Project Templates window and choosing Edit Template Info.... If you would like to change content in the template itself, simply open up a new project using that template, make the necessary changes, then go through the above steps again. You can overwrite the old template with the new one by simply saving it under the same name.

Downloading and Importing Project Templates

If you're a fan of a popular writing methodologies like Save The Cat!, The 5 Act Structure, or The Snowflake Method, you may find that someone else has already created a template suited to that methodology and posted it online for you to download. Have a look through our forums or conduct a quick Google search to see what's already out there. If you find a project template you'd like to use, importing it into Scrivener is easy:

  1. Once you have downloaded the template, make sure it is unzipped before you move on to the next step. On Windows, you can unzip the file by right-clicking on it in your File Explorer and choosing "Extract All." On Mac, simply double-click on the ZIP file to unzip it in your default archive software.
  2. In Scrivener, go to File > New Project... to open up the Project Templates window.
  3. Click the Options dropdown menu, then select Import Templates....
  4. Select the ".scrivtemplate" file you downloaded, and click Import.

The template will now be available under the Fiction category in the Project Templates window, which you can access at any time via File > New Project.... If you would like to change the name, icon, or category of the template, you can do so by right-clicking on the template in the Project Templates window and choosing Edit Template Info....