Embedding vs. Linking Images

There are two ways to add an image to your text in Scrivener. You can embed it into the document, as you would with most traditional word processors, or you can insert it as a linked image. With the former method, you’re importing the image file into the project. With the latter method, the image file stays outside of your project wherever it is located on your hard drive, but is linked to Scrivener so that it can generate the graphic as if it were embedded. With either method, your image will be displayed the same way, but there are caveats to consider when choosing which method to use.

When you embed an image into your document, either via drag and drop or via the Insert > Image from File… command, the size of that image counts toward the size of your project. As a general rule, the smaller a project is, the better Scrivener will perform. So, if your project requires a lot of images, or if those images are very large, this can start to take a toll on Scrivener and you may notice the program becoming sluggish or freezing up when handling your project. This is because Scrivener wasn’t built to handle large image files, and is more suited to creating long text drafts than it is to layout and design. Don’t let this deter you from importing images, though — just be mindful of how many images your project is going to require, and try to stick to smaller image files where possible.

If you do think your project is going to require many images, consider using the other approach: linking your images with the Insert > Image Linked to File… command. This works much like a program shortcut on your PC’s Desktop or in your Mac’s Dock. While the program itself is not actually located on your Desktop or in your Dock, its shortcut allows you to launch the program from that location, because the shortcut icon is linked to the actual program file. Because the image file is not being embedded in the document, it won’t contribute to the size of your project, thus keeping it lightweight.

However, you must keep in mind that if the image file were to be renamed, moved, or deleted, the link to the file in Scrivener would break, and the image would disappear from your document. We recommend creating a dedicated folder on your hard drive for images you’ve linked to Scrivener, so you know not to modify any of the images inside of it. If you sync your project across devices, note that linked images may be temporarily broken when you are working on a device where the images are not stored locally. Do not fret: when you return to the machine that has the images in the linked location, they will link back up again.

For more information, see §15.7.4 Linked Images (§15.6.3 on Windows) in the Scrivener Manual, found under the Help menu.