How do I fix or convert formatting in my project?

Each item in a Scrivener project is a bit like a separate document on your hard drive. They can all have their own independent formatting. You may, for example, wish to have your notes in one font and your draft text in another, to help keep them visually distinct when working in Scrivenings mode. Or you may have started a project with one set of formatting, but then changed your mind and applied different formatting to later documents. You may also have imported documents from other applications, or pasted text from other sources (in which case, you may wish to learn how to paste without carrying formatting along for the ride).

It isn't difficult to have ended up with a project that has a range of various formatting in different documents, and to feel the need to tidy things up.

Setting up Scrivener's Default Formatting

First, you may want to change how text looks by default. Perhaps you've been doing that by hand every time you create a new document, or using a style. You can set up which formatting you would like to use by default:

  • On Windows, use the File ▸ Options... menu command and on the Mac, use Scrivener ▸ Preferences... and then within the Editing pane, click on the Formatting tab.
  • Use the ruler and formatting tools provided to set up the default look of your documents. On the Mac the Aa button on the left of the format bar opens the font options.
  • If you have formatted text in the Editor the way you want the default text to look then you can click the Use Formatting in Current Editor button.

You can also override the global settings for individual projects via Project ▸ Project Settings..., within the Formatting pane. If this option is in use, new documents in the project and those you convert to the default text style will use these settings, not the settings in application preferences.

Alternatively, if you have formatted text in the Editor the way that you want the default formatting to look you can go to Format ▸ Make Formatting Default This will make the currently selected formatting in the editor the default formatting for all new documents, without the need to go into Preferences/Options or Project Settings. When you use the command you will be asked whether you want the formatting to be used in your global application preferences or the just the project settings. In the latter case, if you have not already enabled the option to override formatting in the project it will be set for you.

Normalising Formatting in Existing Text

Default settings only affect documents you create in the future. If you wish to change existing documents to the current default, or clean up some formatting that went awry, select the desired documents in the Binder and choose Documents ▸ Convert ▸ Text to Default Formatting.

After clicking the menu command, a window will pop up asking how much formatting you wish to apply to the selected documents. For example, if you opt to preserve alignment and the document is left-aligned, even if your default formatting is full justification, it will not be applied because you have elected to preserve the original alignment. Convert font only and Remove all styles will each do what you would expect. If you do not select Remove all styles then any text with a style assigned will not be converted to the default formatting.

Ranges of text that have been blocked out with Preserve Formatting will not be altered by the conversion, much in the same way that the compiler will leave them alone.