Footnote Numbering Won't Update in Word

Scrivener supports auto-incrementing footnotes and endnotes in Word when compiling to RTF, to DOC using the default RTF-Based converter or the Microsoft Office converter, and to DOCX using the Microsoft Office converter. To set the converter, go to Tools > Options... and click the Import/Export tab, then the "Export Converters..." button. Select the file format from the drop-down menu on the left, then choose the converter you want from the menu on the right. Microsoft Office converters require MS Office 2007, 2010, or 2013.

Scrivener's default DOCX converter currently supports only fixed footnote and endnote numbering. Deleting or adding footnotes or endnotes to the compiled DOCX will thus not adjust the numbering stream, and changing the footnote or endnote style (e.g. from 1, 2, 3 to a, b, c) will not update the original notes. To correct this, you can use the macro below (posted by Klaus Linke) to delete all footnotes or endnotes and reinsert them using the auto-incrementing style in Microsoft Word. We suggest making a backup copy of the file before running the macro.

(The steps for creating a macro in Word are adapted from a Microsoft support article and apply to Word 2007, 2010, and 2013.)

  1. In Microsoft Word 2010 or 2013, click the Macros button from the View tab. In Word 2007, the Macros button is accessed from the Developer tab, which you can display with these steps:

    1. Click the Microsoft Office Button Office button image, and then click "Word Options".
    2. Click "Popular".
    3. Under "Top options for working with Word", select the "Show Developer tab in the Ribbon" check box. 
  2. In the Macros dialog, enter a name and description for the macro. (Both are required.)
    If you give a new macro the same name as a built-in macro, the new macro actions will replace the built-in macro. To view a list of built-in macros, click Word Commands in the Macros in list.

  3. In the "Macros in" list, click the template or document in which you want to store the macro. To make your macro available in all documents, choose Normal.dotm.

  4. Click "Create" to open the Visual Basic Editor, and paste the following just above the "End Sub" text in the editor:
    To correct footnote numbering:

    Dim myFootnote As Footnote
    Dim i
    For i = ActiveDocument.Footnotes.Count To 1 Step -1
        Set myFootnote = ActiveDocument.Footnotes(i)
        myFootnote.Range.Copy
        myFootnote.Reference.Select
        myFootnote.Delete
        ActiveDocument.Footnotes.Add Selection.Range
        Selection.Footnotes(1).Range.Paste
    Next i
    

    To correct endnote numbering:

    Dim myEndnote As Endnote
    Dim i
    For i = ActiveDocument.Endnotes.Count To 1 Step -1
        Set myEndnote = ActiveDocument.Endnotes(i)
        myEndnote.Range.Copy
        myEndnote.Reference.Select
        myEndnote.Delete
        ActiveDocument.Endnotes.Add Selection.Range
        Selection.Endnotes(1).Range.Paste
    Next i
    
  5. Choose File > Save, then exit Visual Basic.

  6. In Word, click the Macros button again and choose the new macro from the list, then click "Run".